Course Manager for Joomla 2.5

Course Manager and other related extensions (modules, plugins) compatible with the latest long-term Joomla 2.5.x versions.

Component

Course Manager compatible with Joomla 2.5.x/1.7.x

More details...
Module

Module requires Course Manager 2.5/1.7.x component. Only for Joomla 2.5, Joomla 1.7 and Joomla 1.6

More details...
Plugin

Courses Search Plugin (J25 version)

More details...